[Subject Prev][Subject Next][Thread Prev][Thread Next][Subject Index][Thread Index]

[vine-users:025189] Re: GeForce2


> こんにちは 川辺です.
> 引続き PC UNIX 上でお仕事しようかなと思って Vine2.0 を買って
> もらったのですが,自分に与えて頂いた PC のビデオカードが
> GeForce2 とか言うもので,これのカードで動く X サーバの RPM
> はを探しています.
> 
> ちょっと探してみた感じでは NVIDIA と言う会社の Web ページに
> は XFree86 4.0 or 4.0.1 のパッチ(モジュール?) が存在するみた
> いなのですが,出来れば RPM を入れたいと思っています.
> 
> GeForce2 上で動く XFree86(バージョンは 3.X 系,4,X 系でもい
> いです)の RPM の存在をご存知の方がございましたら,教えて頂け
> ますでしょうか?
> 
> 宜しくお願いいたします.
> 
> Tsuyoshi KAWABE

僕はGeForce2カードを使ってLaser5 Linux6.2を使っています。
ぼくの行った順序では、まずXFree86の4.0をinstallする必要があ
ります。僕の場合はLaser5のContribCDに4.0アップデートのための
RPMファイルがあるのでまずこれをinstallしました。
Vine2.0のばあいは、XFree86のWebサイトから4.0のbinaryを録って
くる必要があるのですがそれはかなり面倒です。
僕の試したところではVine2.0にもLaser5のContribCDのXFree86の
アップデートファイルがそのままinstallできたので、Laser5のサ
イトからXFree86-4.0関連のファイルを全部落としてきて、それをi
nstallするとよいでしょう。

その後NVIDIAのサイトからNVIDIA-kernel-0.9-4.src.rpmとNVIDIA-
GLX-0.9-4.src.rpmをとってきてRebuildします。
srcファイルをとってくるところが味噌で、binaryではinstallでき
ますが正常に動作しません。また、0.93もありますが、これも正常
にinstallされないので0.94にしましょう。

こんなところですが、GeForce2ではXFree86を4.0にバージョンアップし
なければならず、3.3.6では絶対動かないです。
また、NVIDIAのサイトでもあるようにNVIDIA-GLX-0.94.rpmはMesa
がinstallしてあるとコンフリクトを起こしてinstallが出來なかっ
たりするので、そのときはrpmコマンドで--forceオプションをつけ
てinstallしてみてください。

こうしてXFree86-4.0とNVIDIA_kernel-0.9-4.rpm、NVIDIA_GLX-0.
9-4.rpmをinstallした後、xf86configを使ってXF86Configファイル
を作ります。そのときに、カードのタイプをNVIDIA RIVA TNT2など
とするとDeviceセクションで
Section "Device" 
    Identifier  "MyCard" 
    Driver      "nv" 
    # VideoRam    32768 
    # Insert Clocks lines here if appropriate 
EndSection
のように定義されます。ここでDriverの"nv"を"nvidia"と書き換え
れば終了。
あとはstartxで起動すればOK。

では。
/////////////////////
K.S
/////////////////////

この情報があなたの探していたものかどうか選択してください。
yes/まさにこれだ!   no/違うなぁ   part/一部見つかった   try/これで試してみる

あなたが探していた情報はどのようなことか、ご自由に記入下さい。特に「まさにこれだ!」と言う場合は記入をお願いします。
例:「複数のマシンからCATV経由でipmasqueradeを利用してWebを参照したい場合の設定について」
Follow-Ups: References: